Critical security vulnerabilities have been identified in the MCP Inspector tool, specifically affecting versions up to 1.0.2 on the 1.x line and up to 2.12.0 on the 2.x line. These vulnerabilities, with CVSS scores of 9.6, could allow a malicious MCP server to execute commands on a user's machine. Notably, these advisories have not yet been registered in major global vulnerability databases like GitHub's or OSV.dev, meaning standard tools like npm audit may not flag projects using the affected versions. Users are advised to manually check their installed MCP Inspector version and update to the latest fixed versions (1.0.3 for 1.x, 2.13.0 for 2.x as of October 30, 2026) or use provided checker tools. AI
IMPACT Critical vulnerabilities in AI tooling could expose users to command execution risks if not promptly addressed.
RANK_REASON The item details security advisories for a specific software tool, MCP Inspector, and discusses how to check for and fix vulnerabilities.
- Common Vulnerability Scoring System
- Dependabot
- GitHub
- local-ai-checkup
- MCP Inspector
- @modelcontextprotocol/inspector
- Munim, Inc.
- n8n
- Ollama
- Open-WebUI
- OSV.dev
- vLLM
AI-generated summary · Google Gemini · from 1 sources. How we write summaries →